-
Identified
Xcelsiors lights being too bright in-game. https://cdn.discordapp.com/attachments/460334338748186654/519303356179546132/RobloxScreenShot20181203_160535883.png
23:05, Dec 10 EDT
-
Update
We have found the solution on why the Xcelsior lights are bright.
Reason: Due to Voxel Lightning had been implemented the Xcelsior lights weren't updated to be compatible with the new Voxel Lightning.
23:08, Dec 10 EDT
-
Fixing
We have sent out our Monkey Workers to fix the problem.
22:15, Dec 15 EDT
-
Resolved
This issue has been fixed.
16:02, Dec 16 EDT
Back to current status