Spawn Glitch

March 02, Sat
Affected Service: MBTA Somerville
  • Identified
    The following station is affected by this Spawn Glitch:
    Cambridge Street (Both Ways)
    Sullivan Station (Upper Level)

    We will be fixing this in the next update.

    16:37, Feb 16 EDT
  • Fixing
    We're currently fixing this glitch and will release it in the next update.

    16:41, Feb 16 EDT
  • Resolved
    Update released.

    13:37, Mar 02 EDT
Back to current status